您的位置是:网站首页>Javascript编程Javascript编程

jquery从哪个版本开始不兼容ie8

少儿编程网2021-12-30 13:30:42Javascript编程 人已围观 来源:少儿编程 -用户投稿

简介jquery从2.0.0版本开始不兼容ie8,不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE浏览器,建议使用原生JS或者Jquery1.x版本,例如Jquery1.12。【相关推荐:jQuery视频教程】jQuery是一个简洁而快速的JavaScript库,可用于

jquery从2.0.0版本开始不兼容ie8,不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE浏览器,建议使用原生JS或者Jquery1.x版本,例如Jquery1.12。N2q少儿编程网-https://www.pxcodes.com

N2q少儿编程网-https://www.pxcodes.com

【相关推荐:jQuery视频教程】N2q少儿编程网-https://www.pxcodes.com

jQuery 是一个简洁而快速的 JavaScript 库,可用于简化事件处理,HTML 文档遍历,Ajax 交互和动画,以便快速开发网站。jQuery 简化了 HTML 的客户端脚本,从而简化了 Web 2.0 应用程序的开发。N2q少儿编程网-https://www.pxcodes.com

jQuery设计的宗旨是“write Less,Do More”,即倡导写更少的代码,做更多的事情。它封装JavaScript常用的功能代码,提供一种简便的JavaScript设计模式,优化HTML文档操作、事件处理、动画设计和Ajax交互。N2q少儿编程网-https://www.pxcodes.com

jQuery的核心特性可以总结为:具有独特的链式语法和短小清晰的多功能接口;具有高效灵活的css选择器,并且可对CSS选择器进行扩展;拥有便捷的插件扩展机制和丰富的插件。N2q少儿编程网-https://www.pxcodes.com

jquery从哪个版本开始不兼容ie8?N2q少儿编程网-https://www.pxcodes.com

jquery从2.0.0版本开始不兼容ie8,不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE浏览器,建议使用原生JS或者Jquery1.x版本。N2q少儿编程网-https://www.pxcodes.com

低版本jq在ie下不报错,高版本jq在ie下报错N2q少儿编程网-https://www.pxcodes.com

N2q少儿编程网-https://www.pxcodes.com

查看2.0.0的源码,只有addEventListener,显然IE不支持这个方法,IE下添加事件监听需要用attachEventN2q少儿编程网-https://www.pxcodes.com

N2q少儿编程网-https://www.pxcodes.com

再看1.11.2的版本源码,有点长,做了对addEventListener的判断,不支持的话走attachEventN2q少儿编程网-https://www.pxcodes.com

N2q少儿编程网-https://www.pxcodes.com

当然这只是使用高版本jq报的第一个错误,事情走到这一步就已经明了了,查看jq*网对浏览器的支持 http://jquery.com/browser-support/N2q少儿编程网-https://www.pxcodes.com

我们找到这样一段话N2q少儿编程网-https://www.pxcodes.com

N2q少儿编程网-https://www.pxcodes.com

英语不好,拿谷歌翻译了一下 :(Current-1)和Current表示我们支持浏览器的当前稳定版本及其之前的版本。 例如,如果当前版本的浏览器是24.x,我们支持24.x和23.x版本。N2q少儿编程网-https://www.pxcodes.com

**后一句话,想要支持ie6-8,使用jq1.12-.N2q少儿编程网-https://www.pxcodes.com

总结起来就是一句话:jQuery2.0.0版本没有attachEvent所以ie8下会报错(当然ie8下报错不止这一个原因,但这是要想修复高版本jq在ie8下报错首先要解决的问题,这回牵扯出一系列的ie8兼容问题,这些兼容问题jq1.12-已经解决了,*方推荐ie8下使用1.12还是有原因的)N2q少儿编程网-https://www.pxcodes.com

更多编程相关知识,请访问:编程视频!!

以上就是jquery从哪个版本开始不兼容ie8的详细内容,更多请关注少儿编程网其它相关文章!N2q少儿编程网-https://www.pxcodes.com

来源:php中文网N2q少儿编程网-https://www.pxcodes.com


相关文章:

支持一下 ( )

jquery从哪个版本开始不兼容ie8

      匿名评论
    • 评论
    人参与,条评论
    jquery从哪个版本开始不兼容ie8

微信公众号

免费视频教程

先知道